Development

sfBookPT-brInstallation (diff)

You must first sign up to be able to contribute.

Changes between Version 21 and Version 22 of sfBookPT-brInstallation

Show
Ignore:
Author:
hpoyatos (IP: 200.252.229.162)
Timestamp:
07/31/06 23:20:21 (11 years ago)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • sfBookPT-brInstallation

    v21 v22  
    2121Note que o framework symfony evolui rapidamente, e uma nova versão estável pode ser lançada apenas um poucos dias depois de sua primeira instalação. Você deve pensar na atualização do framework como uma grande preocupação, e é por essa razão que a primeira solução não é recomendada se você for desenvolver um website para valer. De fato, uma aplicação desenvolvida com um sandbox não pode ser atualizada facilmente. 
    2222 
    23 Pré-requisitos 
     23== Pré-requisitos == 
    2424 
    2525Para fazer uso do symfony, você precisa ter o PHP5 e um servidor web instalados. Se você for realizar uma instalação PEAR , você também precisará ter o [http://pear.php.net/ PEAR]. Se você planeja usar de persistência de dados, um banco de dados também será necessário. Symfony é compatível com MySQL, PostgreSQL, Oracle, Microsoft SQL Server (MSSQL), e qualquer outro banco de dados que possuir um driver [http://creole.phpdb.org/trac/ Creole]. 
    3535}}} 
    3636 
    37 O sandbox 
     37== O sandbox == 
    3838 
    3939O sandbox é um simples pacote de arquivos. Ele contém um projeto symfony vazio onde todas as bibliotecas necessárias (symfony, pake, creole, propel and phing) já estão incluídas. Para instalá-lo, apenas desempacote este arquivo no diretório web raiz configurado para seu servidor (geralmente web/). Ele irá funcionar "fora da caixa", sem qualquer necessidade de configuração ou pacotes adicionais.