Development

Upgrade1.1-CreateProjectConfig

You must first sign up to be able to contribute.

Version 3 (modified by GaryFx, 9 years ago)
--

Create a config/ProjectConfiguration.class.php file. This is the main file for controlling your configuration, and in particular, controlling which version of symfony you use.

You can copy the skeleton ProjectConfiguration.class.php file from the symfony project skeleton directly:

$ cp $SYMFONY_1_1/lib/task/generator/skeleton/project/config/ProjectConfiguration.class.php config/ProjectConfiguration.class.php

or you can create it manually with the following content:

<?php
require_once '##SYMFONY_LIB_DIR##/autoload/sfCoreAutoload.class.php';
sfCoreAutoload::register();

class ProjectConfiguration extends sfProjectConfiguration
{
  public function setup()
  {
  }
}

Either way, you must replace the ##SYMFONY_LIB_DIR## with the path to your symfony 1.1 lib directory. This is the new way to change the symfony version used for your project.

Next step:Run the project:upgrade1.1 task