IRCLogs20110120 (diff)

You must first sign up to be able to contribute.

Changes between Version 1 and Version 2 of IRCLogs20110120

lsmith (IP:
01/25/11 14:43:48 (7 years ago)



  • IRCLogs20110120

    v1 v2  
     5== Template names == 
     7The main concern with the approach of renderer.format was that IDE's will not handle this out of the box and many not even via configuration. As a result it was agreed to revert back to format.renderer. 
     9== Package / Dependency Management for Bundles == 
     11Benjamin reported that he (and Nils) had reviewed Pyrus for our use case an found the code insufficient out of the box and not clean enough for extending. He proposed to write a client companion for Pirum that is based on the package.xml, but adds optional extensions where needed. It was decided to leave this topic in the hands of Nils for now. 
     13== refactored bundle management == 
     15Now that the bundle handling has been refactored, making things more flexible the best practices need to be reviewed so that they can be baked into init:bundle. However no decisions were made. The behavior of the new getParent() method to allow extending 3rd party bundles was discussed in much detail 
     17== Change option naming convention to camelcase == 
     19In general there was agreement that the situation of having underscore in YAML, dash in XML and camelcase in PHP to be quite annoying. However as YAML/XML is used to set config options inside PHP code its hard to find a solution. Jeremy also raised the questions how we deal with acronym case to which the unanimous reply was ucfirst(). Considering that changing this will have a huge impact and there wasn't total agreement on one approach the topic was shelved for now. 
     21== load extension configs once == 
     23It was agreed that Johannes approach is the right starting point. However there was a lot of back and forth if there should be a separate merge method or not and which parts of the API should be public. 
     25== Request changes == 
     27Bulat suggested moving the population of Request with the request parameters to the kernel. This would enable easier handling of alternate methods for other methods of passing request parameters. The suggestion was deemed plausible. 
     29== Parameter converters == 
     31Bulat advocated "making explicit registration of parameter converter per parameter would allow for bi-directional conversion". Fabien made it clear he wants the routing rules to remain focused on routing, due to the bad experience with ObjectRoute's in sf 1.x. Jordi said he would prefer this be handled inside the Controllers via Annotations, which Fabien mentioned he started in FrameworkExtraBundle. Henrik suggested that it might be a good idea to move the current parameter converted out of core. Bulat said he will work on the concept some more. Finally Jordi mentioned that he is planning to submit a Serializer component which enables encoding and decoding data structures which should be useful for parameter converters. 
    533= IRC logs =