Development

IRCLogs20101125 (diff)

You must first sign up to be able to contribute.

Changes between Version 3 and Version 4 of IRCLogs20101125

Show
Ignore:
Author:
lsmith (IP: 217.162.131.234)
Timestamp:
11/27/10 12:06:20 (6 years ago)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • IRCLogs20101125

    v3 v4  
    1010 
    1111== Method naming conventions == 
    12 Fabien said he has been working on applying method naming conventions in a branch, though most of these conventions had already been used across the code base. Everybody seemed to agree with the choices there, but proposed a few more scenarios. Jordi pointed out that for naming he is also concerned about how parameters are named: "request = $_POST, query = $_GET, attributes = routing". While the reasons for the naming are clear its hard to remember them. Jordi also raised that Bundle naming seems redundant: "Bundle/FooBundle/Bundle()". But Benjamin pointed out that the repition makes sense since one can have a "use" statement without an alias in which case the class name needs to be clear on its own. Johan also pointed out that container isn't such a clear concept making it unclear what get(). Bulat suggested potentially renaming the class from Container to ServiceContainer. However there was no agreement. 
     12Fabien said he has been working on applying method naming conventions in a branch, though most of these conventions had already been used across the code base. Everybody seemed to agree with the choices there, but proposed a few more scenarios. Jordi pointed out that for naming he is also concerned about how parameters are named: "request = $_POST, query = $_GET, attributes = routing". While the reasons for the naming are clear its hard to remember them. Jordi also raised that Bundle naming seems redundant: "Bundle/FooBundle/Bundle()". But Benjamin pointed out that the repition makes sense since one can have a "use" statement without an alias in which case the class name needs to be clear on its own. Johan also pointed out that container isn't such a clear concept making it unclear what get(). Bulat suggested potentially renaming the class from Container to `ServiceContainer`. However there was no agreement. 
    1313 
    1414== Flash messages and i18n  ==